summaryrefslogtreecommitdiff
path: root/Omni/Cloud/Mail.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Cloud/Mail.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Cloud/Mail.nix')
-rw-r--r--Omni/Cloud/Mail.nix24
1 files changed, 11 insertions, 13 deletions
diff --git a/Omni/Cloud/Mail.nix b/Omni/Cloud/Mail.nix
index fa99cf3..d3f70bc 100644
--- a/Omni/Cloud/Mail.nix
+++ b/Omni/Cloud/Mail.nix
@@ -1,12 +1,11 @@
-{ ... }:
+{...}:
+/*
+Known issues:
-/* Known issues:
-
- - when the acme cert gets refreshed, you need to manually restart dovecot
- - when restarting dovecot, it might hang, in that case do:
- systemctl --job-mode=ignore-dependencies restart dovecot2 postfix
+- when the acme cert gets refreshed, you need to manually restart dovecot
+- when restarting dovecot, it might hang, in that case do:
+ systemctl --job-mode=ignore-dependencies restart dovecot2 postfix
*/
-
{
mailserver = {
enable = true;
@@ -15,7 +14,7 @@
alertAddress = "bsima@me.com";
};
fqdn = "simatime.com";
- domains = [ "simatime.com" "bsima.me" ];
+ domains = ["simatime.com" "bsima.me"];
certificateScheme = 3; # let's encrypt
enableImap = true;
enablePop3 = true;
@@ -35,18 +34,17 @@
"postmaster@simatime.com"
"abuse@simatime.com"
];
- catchAll = [ "simatime.com" "bsima.me" ];
+ catchAll = ["simatime.com" "bsima.me"];
quota = "10G";
};
"dev@simatime.com" = {
hashedPasswordFile = "/home/ben/hashed-mail-password";
- aliases = [ "dev@bsima.me" ];
+ aliases = ["dev@bsima.me"];
quota = "10G";
};
"nick@simatime.com" = {
- hashedPassword =
- "$6$31P/Mg8k8Pezy1e$Fn1tDyssf.1EgxmLYFsQpSq6RP4wbEvP/UlBlXQhyKA9FnmFtJteXsbJM1naa8Kyylo8vZM9zmeoSthHS1slA1";
- aliases = [ "nicolai@simatime.com" ];
+ hashedPassword = "$6$31P/Mg8k8Pezy1e$Fn1tDyssf.1EgxmLYFsQpSq6RP4wbEvP/UlBlXQhyKA9FnmFtJteXsbJM1naa8Kyylo8vZM9zmeoSthHS1slA1";
+ aliases = ["nicolai@simatime.com"];
quota = "1G";
};
};