summaryrefslogtreecommitdiff
path: root/Omni/Cloud/Networking.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Cloud/Networking.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Cloud/Networking.nix')
-rw-r--r--Omni/Cloud/Networking.nix25
1 files changed, 14 insertions, 11 deletions
diff --git a/Omni/Cloud/Networking.nix b/Omni/Cloud/Networking.nix
index 1c1f832..419433b 100644
--- a/Omni/Cloud/Networking.nix
+++ b/Omni/Cloud/Networking.nix
@@ -1,8 +1,8 @@
-{ lib, ... }: {
+{lib, ...}: {
# This file was populated at runtime with the networking
# details gathered from the active system.
networking = {
- nameservers = [ "8.8.8.8" ];
+ nameservers = ["8.8.8.8"];
defaultGateway = "143.198.112.1";
defaultGateway6 = "2604:a880:400:d0::1";
dhcpcd.enable = false;
@@ -29,16 +29,19 @@
prefixLength = 64;
}
];
- ipv4.routes = [{
- address = "143.198.112.1";
- prefixLength = 32;
- }];
- ipv6.routes = [{
- address = "2604:a880:400:d0::1";
- prefixLength = 128;
- }];
+ ipv4.routes = [
+ {
+ address = "143.198.112.1";
+ prefixLength = 32;
+ }
+ ];
+ ipv6.routes = [
+ {
+ address = "2604:a880:400:d0::1";
+ prefixLength = 128;
+ }
+ ];
};
-
};
};
services.udev.extraRules = ''