summaryrefslogtreecommitdiff
path: root/Omni/Cloud/NostrRelay.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Cloud/NostrRelay.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Cloud/NostrRelay.nix')
-rw-r--r--Omni/Cloud/NostrRelay.nix15
1 files changed, 8 insertions, 7 deletions
diff --git a/Omni/Cloud/NostrRelay.nix b/Omni/Cloud/NostrRelay.nix
index 0be8a6f..1bcf99b 100644
--- a/Omni/Cloud/NostrRelay.nix
+++ b/Omni/Cloud/NostrRelay.nix
@@ -1,6 +1,8 @@
-{ config, pkgs, ... }:
-
-let
+{
+ config,
+ pkgs,
+ ...
+}: let
ports = import ./Ports.nix;
dataDir = "/var/lib/nostr-rs-relay";
# https://git.sr.ht/~gheartsfield/nostr-rs-relay/tree/master/config.toml
@@ -19,16 +21,15 @@ let
'';
in {
config.systemd.services.nostr-relay = {
- path = [ pkgs.nostr-rs-relay ];
- wantedBy = [ "multi-user.target" ];
+ path = [pkgs.nostr-rs-relay];
+ wantedBy = ["multi-user.target"];
preStart = ''
mkdir -p ${dataDir}
cat "${cfg}" > ${dataDir}/config.toml
'';
script = "nostr-rs-relay --db ${dataDir}";
serviceConfig = {
- Environment =
- [ "RUST_LOG=info,nostr_rs_relay=info" "APP_DATA=${dataDir}" ];
+ Environment = ["RUST_LOG=info,nostr_rs_relay=info" "APP_DATA=${dataDir}"];
WorkingDirectory = dataDir;
KillSignal = "INT";
Type = "simple";