summaryrefslogtreecommitdiff
path: root/Omni/Cloud/Web.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-15 14:35:18 -0500
committerBen Sima <ben@bsima.me>2025-01-15 14:35:18 -0500
commitc1bce512ef31faf044de32dc79e6191389469250 (patch)
treecd96682ccec60032fdc1a2f1efe8d3556ad7b8e7 /Omni/Cloud/Web.nix
parentd2edf150cf2c876971383a4a484f289ce7e7f680 (diff)
Make blog available at bensima.com
Slowly moving everything to this domain, it will take a while though.
Diffstat (limited to 'Omni/Cloud/Web.nix')
-rw-r--r--Omni/Cloud/Web.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/Omni/Cloud/Web.nix b/Omni/Cloud/Web.nix
index df62aa3..fe7d64f 100644
--- a/Omni/Cloud/Web.nix
+++ b/Omni/Cloud/Web.nix
@@ -132,7 +132,7 @@ in {
};
};
- "bsima.me" = {
+ "bensima.com" = {
locations."/" = {
root = "/var/web/ben";
index = "index.html index.htm";
@@ -140,7 +140,11 @@ in {
autoindex on;
'';
};
- serverAliases = ["www.bsima.me"];
+ serverAliases = [
+ "www.bensima.com"
+ "www.bsima.me"
+ "bsima.me"
+ ];
forceSSL = true;
useACMEHost = rootDomain;
};
@@ -268,7 +272,7 @@ in {
group = "nginx";
# This must contain all of the other domains we host
extraDomainNames =
- ["bsima.me" "www.bsima.me"]
+ ["bensima.com" "www.bensima.com" "bsima.me" "www.bsima.me"]
++ map (sub: "${sub}.${rootDomain}") [
"music"
"tv"