summaryrefslogtreecommitdiff
path: root/Omni/Dev/Beryllium/Configuration.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Dev/Beryllium/Configuration.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Dev/Beryllium/Configuration.nix')
-rw-r--r--Omni/Dev/Beryllium/Configuration.nix17
1 files changed, 8 insertions, 9 deletions
diff --git a/Omni/Dev/Beryllium/Configuration.nix b/Omni/Dev/Beryllium/Configuration.nix
index 16f4bca..69c83a6 100644
--- a/Omni/Dev/Beryllium/Configuration.nix
+++ b/Omni/Dev/Beryllium/Configuration.nix
@@ -1,8 +1,8 @@
-{ pkgs, ... }:
-
-let ports = import ../../Cloud/Ports.nix;
+{pkgs, ...}: let
+ ports = import ../../Cloud/Ports.nix;
in {
- imports = [ # Include the results of the hardware scan.
+ imports = [
+ # Include the results of the hardware scan.
./Hardware.nix
];
@@ -10,8 +10,8 @@ in {
boot.loader.systemd-boot.enable = true;
boot.loader.efi.canTouchEfiVariables = true;
- boot.kernelModules = [ "v4l2loopback" ];
- boot.extraModulePackages = [ pkgs.linuxPackages.v4l2loopback ];
+ boot.kernelModules = ["v4l2loopback"];
+ boot.extraModulePackages = [pkgs.linuxPackages.v4l2loopback];
# Enable networking
networking.networkmanager.enable = true;
@@ -68,7 +68,7 @@ in {
hardware.opengl.enable = true;
hardware.opengl.driSupport32Bit = true;
- services.xserver.videoDrivers = [ "nvidia" ];
+ services.xserver.videoDrivers = ["nvidia"];
hardware.nvidia.nvidiaPersistenced = true;
hardware.nvidia.modesetting.enable = true;
hardware.nvidia.powerManagement.enable = false;
@@ -103,7 +103,7 @@ in {
systemd.services.NetworkManager-wait-online.enable = false;
- networking.firewall.allowedTCPPorts = [ ports.barrier ];
+ networking.firewall.allowedTCPPorts = [ports.barrier];
# This value determines the NixOS release from which the default
# settings for stateful data, like file locations and database versions
# on your system were taken. It‘s perfectly fine and recommended to leave
@@ -111,5 +111,4 @@ in {
# Before changing this value read the documentation for this option
# (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
system.stateVersion = "23.05"; # Did you read the comment?
-
}