summaryrefslogtreecommitdiff
path: root/Omni/Dev/Beryllium/Ollama.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Dev/Beryllium/Ollama.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Dev/Beryllium/Ollama.nix')
-rw-r--r--Omni/Dev/Beryllium/Ollama.nix29
1 files changed, 15 insertions, 14 deletions
diff --git a/Omni/Dev/Beryllium/Ollama.nix b/Omni/Dev/Beryllium/Ollama.nix
index 35b4fe1..0018f49 100644
--- a/Omni/Dev/Beryllium/Ollama.nix
+++ b/Omni/Dev/Beryllium/Ollama.nix
@@ -1,19 +1,20 @@
-{ pkgs, ... }:
-/* Ollama API service
+{pkgs, ...}:
+/*
+Ollama API service
- Don't put too much work into this, there's a much better and more complete
- ollama service (with webui!) being built here:
- https://github.com/NixOS/nixpkgs/pull/275448
+Don't put too much work into this, there's a much better and more complete
+ollama service (with webui!) being built here:
+https://github.com/NixOS/nixpkgs/pull/275448
- If you want to spend time on it, spend time over there.
+If you want to spend time on it, spend time over there.
*/
-let pkg = pkgs.unstable.ollama;
+let
+ pkg = pkgs.unstable.ollama;
in {
-
systemd.services.ollama = {
description = "ollama";
- after = [ "network.target" ];
- wantedBy = [ "multi-user.target" ];
+ after = ["network.target"];
+ wantedBy = ["multi-user.target"];
environment = {
OLLAMA_HOST = "localhost:11434";
@@ -31,18 +32,18 @@ in {
Restart = "on-failure";
RestartSec = 3;
# Persistent storage for model files, i.e. /var/lib/<StateDirectory>
- StateDirectory = [ "ollama" ];
+ StateDirectory = ["ollama"];
};
};
# for administration, make this available to users' PATH
- environment.systemPackages = [ pkg ];
+ environment.systemPackages = [pkg];
- users.groups.ollama = { };
+ users.groups.ollama = {};
users.users.ollama = {
group = "ollama";
isSystemUser = true;
- extraGroups = [ "render" "video" ];
+ extraGroups = ["render" "video"];
};
}