summaryrefslogtreecommitdiff
path: root/Omni/Dev/Guix.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Dev/Guix.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Dev/Guix.nix')
-rw-r--r--Omni/Dev/Guix.nix24
1 files changed, 11 insertions, 13 deletions
diff --git a/Omni/Dev/Guix.nix b/Omni/Dev/Guix.nix
index 0b261fb..837e5f2 100644
--- a/Omni/Dev/Guix.nix
+++ b/Omni/Dev/Guix.nix
@@ -1,13 +1,12 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-let
-
+{
+ config,
+ lib,
+ pkgs,
+ ...
+}:
+with lib; let
cfg = config.services.guix;
-
in {
-
options.services.guix = {
enable = mkEnableOption "GNU Guix package manager";
};
@@ -16,12 +15,11 @@ in {
systemd.services.guix-daemon = {
description = "Build daemon for GNU Guix";
- wantedBy = [ "multi-user.target" ];
+ wantedBy = ["multi-user.target"];
serviceConfig = {
Restart = "always";
- ExecStart =
- "${pkgs.guix}/bin/guix-daemon --build-users-group=guixbuild";
+ ExecStart = "${pkgs.guix}/bin/guix-daemon --build-users-group=guixbuild";
Environment = null;
RemainAfterExit = "yes";
StandardOutput = "syslog";
@@ -33,11 +31,11 @@ in {
extraUsers = lib.attrs.genAttrs (lib.lists.range 1 10) (n: {
name = "guixbuilder${n}";
isSystemUser = true;
- extraGroups = [ "guixbuild" ];
+ extraGroups = ["guixbuild"];
group = "guixbuild";
description = "Guix build user ${n}";
});
- extraGroups = { "guixbuild" = { }; };
+ extraGroups = {"guixbuild" = {};};
};
};
}