summaryrefslogtreecommitdiff
path: root/Omni/Dev/Hoogle.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Dev/Hoogle.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Dev/Hoogle.nix')
-rw-r--r--Omni/Dev/Hoogle.nix26
1 files changed, 12 insertions, 14 deletions
diff --git a/Omni/Dev/Hoogle.nix b/Omni/Dev/Hoogle.nix
index 213a31c..1a4ab51 100644
--- a/Omni/Dev/Hoogle.nix
+++ b/Omni/Dev/Hoogle.nix
@@ -1,18 +1,17 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-let
-
+{
+ config,
+ lib,
+ pkgs,
+ ...
+}:
+with lib; let
cfg = config.services.my-hoogle;
hoogleEnv = pkgs.buildEnv {
name = "hoogle";
- paths = [ (cfg.haskellPackages.ghcWithHoogle cfg.packages) ];
+ paths = [(cfg.haskellPackages.ghcWithHoogle cfg.packages)];
};
-
in {
-
options.services.my-hoogle = {
enable = mkEnableOption "Haskell documentation server";
@@ -25,7 +24,7 @@ in {
};
packages = mkOption {
- default = _hp: [ ];
+ default = _hp: [];
defaultText = "hp: []";
example = "hp: with hp; [ text lens ]";
description = ''
@@ -60,13 +59,13 @@ in {
systemd.services.hoogle = {
description = "Haskell documentation server";
- wantedBy = [ "multi-user.target" ];
+ wantedBy = ["multi-user.target"];
serviceConfig = {
Restart = "always";
ExecStart = "${hoogleEnv}/bin/hoogle server --local --port ${
- toString cfg.port
- } --home ${cfg.home} --host ${cfg.host}";
+ toString cfg.port
+ } --home ${cfg.home} --host ${cfg.host}";
DynamicUser = true;
@@ -77,5 +76,4 @@ in {
};
};
};
-
}