summaryrefslogtreecommitdiff
path: root/Omni/Dev/Networking.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-15 19:21:06 -0500
committerBen Sima <ben@bsima.me>2025-01-15 19:21:06 -0500
commit1ff23133ff4ccdb097f7a38c28544180937a9b38 (patch)
treefa5d250a98898fe6fa8aecb7275f8841bdb16b22 /Omni/Dev/Networking.nix
parentc1bce512ef31faf044de32dc79e6191389469250 (diff)
Move Networking.nix under Lithium
This should have been done before as it only pertains to Lithium.
Diffstat (limited to 'Omni/Dev/Networking.nix')
-rw-r--r--Omni/Dev/Networking.nix42
1 files changed, 0 insertions, 42 deletions
diff --git a/Omni/Dev/Networking.nix b/Omni/Dev/Networking.nix
deleted file mode 100644
index f7ea6e3..0000000
--- a/Omni/Dev/Networking.nix
+++ /dev/null
@@ -1,42 +0,0 @@
-{...}: let
- ports = import ../Cloud/Ports.nix;
-in {
- networking = {
- nameservers = ["1.1.1.1"];
- hostName = "lithium";
- hosts = {"::1" = ["localhost" "ipv6-localhost" "ipv6-loopback"];};
-
- firewall = {
- allowedTCPPorts = [
- ports.bitcoind
- ports.bitcoind-rpc
- ports.delugeWeb
- ports.et
- ports.gemini
- ports.git
- ports.http
- ports.https
- ports.jellyfin
- ports.jupyter
- ports.k3s
- ports.mpd
- ports.mpd-stream
- ports.murmur
- ports.radicale
- ports.sabten
- ports.ssh
- ports.stableDiffusion
- ports.tor
- ];
- allowedTCPPortRanges = [ports.torrents ports.httpdev];
- allowedUDPPorts = [ports.dns ports.et ports.murmur];
- allowedUDPPortRanges = [ports.torrents];
- };
-
- # The global useDHCP flag is deprecated, therefore explicitly set to false here.
- # Per-interface useDHCP will be mandatory in the future, so this generated config
- # replicates the default behaviour.
- useDHCP = false;
- interfaces.enp2s0.useDHCP = true;
- };
-}