summaryrefslogtreecommitdiff
path: root/Omni/Os/Base.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Os/Base.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Os/Base.nix')
-rw-r--r--Omni/Os/Base.nix18
1 files changed, 8 insertions, 10 deletions
diff --git a/Omni/Os/Base.nix b/Omni/Os/Base.nix
index 8e301e1..c18ca1d 100644
--- a/Omni/Os/Base.nix
+++ b/Omni/Os/Base.nix
@@ -1,19 +1,17 @@
-{ config, ... }:
-
+{config, ...}:
# This module defines common default settings that all OS builds should include.
-
-let ports = import ../Cloud/Ports.nix;
+let
+ ports = import ../Cloud/Ports.nix;
in {
boot.tmp.cleanOnBoot = true;
networking.firewall.allowPing = true;
- nix.settings.substituters =
- [ "https://cache.nixos.org" ]; # "ssh://dev.simatime.com" ];
+ nix.settings.substituters = ["https://cache.nixos.org"]; # "ssh://dev.simatime.com" ];
nix.gc.automatic = true;
nix.gc.dates = "Sunday 02:15";
nix.optimise.automatic = true;
- nix.optimise.dates = [ "Sunday 02:30" ];
- nix.settings.extra-sandbox-paths = [ config.programs.ccache.cacheDir ];
- nix.settings.trusted-users = [ "ben" ];
+ nix.optimise.dates = ["Sunday 02:30"];
+ nix.settings.extra-sandbox-paths = [config.programs.ccache.cacheDir];
+ nix.settings.trusted-users = ["ben"];
programs.ccache.enable = true;
programs.mosh.enable = true;
programs.mosh.withUtempter = true;
@@ -23,7 +21,7 @@ in {
services.clamav.daemon.enable = true; # security
services.clamav.updater.enable = true; # security
services.fail2ban.enable = true; # security
- services.fail2ban.ignoreIP = [ ports.bensIp ]; # my home IP
+ services.fail2ban.ignoreIP = [ports.bensIp]; # my home IP
services.fail2ban.maxretry = 10;
services.openssh.enable = true;
services.openssh.openFirewall = true;