summaryrefslogtreecommitdiff
path: root/Omni/Os/Boot.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Os/Boot.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Os/Boot.nix')
-rw-r--r--Omni/Os/Boot.nix23
1 files changed, 12 insertions, 11 deletions
diff --git a/Omni/Os/Boot.nix b/Omni/Os/Boot.nix
index c789d89..bfbae8c 100644
--- a/Omni/Os/Boot.nix
+++ b/Omni/Os/Boot.nix
@@ -1,14 +1,15 @@
-{ bild }:
-/* This target creates a qcow2 image of a barebones NixOS VM which should be used
- to bootstrap a deployment target.
+{bild}:
+/*
+This target creates a qcow2 image of a barebones NixOS VM which should be used
+to bootstrap a deployment target.
- The workflow is like this:
+The workflow is like this:
- - bild this, you get a qcow2 image
- - go to https://cloud.digitalocean.com/images/custom_images
- - upload the image
- - start a new droplet with this image
- - once fully provisioned and accessible via ssh, the new droplet can be a deploy
- target for any other namespace
+- bild this, you get a qcow2 image
+- go to https://cloud.digitalocean.com/images/custom_images
+- upload the image
+- start a new droplet with this image
+- once fully provisioned and accessible via ssh, the new droplet can be a deploy
+ target for any other namespace
*/
-bild.droplet { imports = [ ./Base.nix ../Users.nix ]; }
+bild.droplet {imports = [./Base.nix ../Users.nix];}