summaryrefslogtreecommitdiff
path: root/Omni/Users.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Users.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Users.nix')
-rw-r--r--Omni/Users.nix21
1 files changed, 11 insertions, 10 deletions
diff --git a/Omni/Users.nix b/Omni/Users.nix
index b214704..043c5fd 100644
--- a/Omni/Users.nix
+++ b/Omni/Users.nix
@@ -1,6 +1,8 @@
-{ config, lib, ... }:
-
-let
+{
+ config,
+ lib,
+ ...
+}: let
readKeys = k:
lib.trivial.pipe k [
builtins.readFile
@@ -10,7 +12,7 @@ let
in {
users.groups = {
# group for publishing web data
- "www-data" = { };
+ "www-data" = {};
};
users.motd = ''
@@ -26,7 +28,7 @@ in {
isNormalUser = true;
home = "/home/deploy";
openssh.authorizedKeys.keys = readKeys ./Keys/Deploy.pub;
- extraGroups = [ "wheel" ];
+ extraGroups = ["wheel"];
};
#
# humans
@@ -38,23 +40,22 @@ in {
isNormalUser = true;
home = "/home/ben";
openssh.authorizedKeys.keys = readKeys ./Keys/Ben.pub;
- extraGroups = [ "wheel" "docker" "bitcoind-mainnet" "git" ];
- hashedPassword =
- "$6$SGhdoRB6DhWe$elW8RQE1ebe8JKf1ALW8jGZTPCyn2rpq/0J8MV/A9y8qFMEhA.Z2eiexMgptohZAK5kcGOc6HIUgNzJqnDUvY.";
+ extraGroups = ["wheel" "docker" "bitcoind-mainnet" "git"];
+ hashedPassword = "$6$SGhdoRB6DhWe$elW8RQE1ebe8JKf1ALW8jGZTPCyn2rpq/0J8MV/A9y8qFMEhA.Z2eiexMgptohZAK5kcGOc6HIUgNzJqnDUvY.";
};
dre = {
description = "Andres Ulloa";
isNormalUser = true;
home = "/home/dre";
openssh.authorizedKeys.keys = readKeys ./Keys/Dre.pub;
- extraGroups = [ "wheel" "git" ];
+ extraGroups = ["wheel" "git"];
};
nick = {
description = "Nick Sima";
isNormalUser = true;
home = "/home/nick";
openssh.authorizedKeys.keys = readKeys ./Keys/Nick.pub;
- extraGroups = [ "docker" "git" ];
+ extraGroups = ["docker" "git"];
};
};
}