summaryrefslogtreecommitdiff
path: root/Urbit/Ship.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Urbit/Ship.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Urbit/Ship.nix')
-rw-r--r--Urbit/Ship.nix27
1 files changed, 13 insertions, 14 deletions
diff --git a/Urbit/Ship.nix b/Urbit/Ship.nix
index bde6b20..a82d880 100644
--- a/Urbit/Ship.nix
+++ b/Urbit/Ship.nix
@@ -1,7 +1,5 @@
-{ bild }:
-
+{bild}:
# This represents a single ship running in a container.
-
let
# bootstrap & startup process, expects two files:
# - /ship.name: containing a ship name like 'sampel-palnet'
@@ -23,17 +21,18 @@ let
/bin/urbit -tq "$pier"
'';
-in bild.image {
- name = "urbit-ship";
- tag = "latest";
+in
+ bild.image {
+ name = "urbit-ship";
+ tag = "latest";
- fromImage = null; # scratch
+ fromImage = null; # scratch
- contents = bild.pkgs.urbit;
+ contents = bild.pkgs.urbit;
- config = {
- Cmd = [ "${urbit-start}" ];
- WorkingDir = "/";
- Volumes = { "/" = { }; };
- };
-}
+ config = {
+ Cmd = ["${urbit-start}"];
+ WorkingDir = "/";
+ Volumes = {"/" = {};};
+ };
+ }