summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /default.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/default.nix b/default.nix
index 5f9f776..eb67a8e 100644
--- a/default.nix
+++ b/default.nix
@@ -1,3 +1,4 @@
-let nixpkgs = import ./Omni/Bild/Nixpkgs.nix;
-in { bild = import ./Omni/Bild.nix { inherit nixpkgs; }; } // nixpkgs
-
+let
+ nixpkgs = import ./Omni/Bild/Nixpkgs.nix;
+in
+ {bild = import ./Omni/Bild.nix {inherit nixpkgs;};} // nixpkgs