summaryrefslogtreecommitdiff
path: root/Omni/Bild/Deps/llm-ollama.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Bild/Deps/llm-ollama.nix')
-rw-r--r--Omni/Bild/Deps/llm-ollama.nix27
1 files changed, 17 insertions, 10 deletions
diff --git a/Omni/Bild/Deps/llm-ollama.nix b/Omni/Bild/Deps/llm-ollama.nix
index e2b6a66..15b26cc 100644
--- a/Omni/Bild/Deps/llm-ollama.nix
+++ b/Omni/Bild/Deps/llm-ollama.nix
@@ -1,5 +1,13 @@
-{ buildPythonPackage, fetchFromGitHub, lib, llm, ollama, pytestCheckHook
-, setuptools, pythonOlder, }:
+{
+ buildPythonPackage,
+ fetchFromGitHub,
+ lib,
+ llm,
+ ollama,
+ pytestCheckHook,
+ setuptools,
+ pythonOlder,
+}:
buildPythonPackage rec {
pname = "llm-ollama";
version = "0.3.0";
@@ -14,27 +22,26 @@ buildPythonPackage rec {
hash = "sha256-Ar0Ux8BNGY0i764CEk7+48J6jnndlRIIMPZ9tFpXiy4=";
};
- nativeBuildInputs = [ setuptools ];
+ nativeBuildInputs = [setuptools];
- buildInputs = [ llm ollama ];
+ buildInputs = [llm ollama];
- propagatedBuildInputs = [ ollama ];
+ propagatedBuildInputs = [ollama];
disabledTests = [
# wants to mkdir in the /homeless-shelter
"test_registered_models"
];
- nativeCheckInputs = [ pytestCheckHook ];
+ nativeCheckInputs = [pytestCheckHook];
- pythonImportsCheck = [ "llm_ollama" ];
+ pythonImportsCheck = ["llm_ollama"];
meta = with lib; {
homepage = "https://github.com/taketwo/llm-ollama";
- description =
- "LLM plugin providing access to local Ollama models usting HTTP API";
+ description = "LLM plugin providing access to local Ollama models usting HTTP API";
changelog = "https://github.com/taketwo/llm-ollama/releases/tag/${version}";
license = licenses.asl20;
- maintainers = with maintainers; [ bsima ];
+ maintainers = with maintainers; [bsima];
};
}