summaryrefslogtreecommitdiff
path: root/Omni/Cloud/Chat.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Cloud/Chat.nix')
-rw-r--r--Omni/Cloud/Chat.nix48
1 files changed, 28 insertions, 20 deletions
diff --git a/Omni/Cloud/Chat.nix b/Omni/Cloud/Chat.nix
index 7f86621..a3a6a78 100644
--- a/Omni/Cloud/Chat.nix
+++ b/Omni/Cloud/Chat.nix
@@ -1,4 +1,8 @@
-{ config, pkgs, ... }:
+{
+ config,
+ pkgs,
+ ...
+}:
#
# a homeserver for matrix.org.
#
@@ -24,17 +28,21 @@ in {
enable = false;
settings.server_name = config.networking.domain;
#registration_shared_secret = "AkGRWSQLga3RoKRFnHhKoeCEIeZzu31y4TRzMRkMyRbBnETkVTSxilf24qySLzQn";
- settings.listeners = [{
- port = matrix_port;
- bind_address = "::1";
- type = "http";
- tls = false;
- x_forwarded = true;
- resources = [{
- names = [ "client" "federation" ];
- compress = false;
- }];
- }];
+ settings.listeners = [
+ {
+ port = matrix_port;
+ bind_address = "::1";
+ type = "http";
+ tls = false;
+ x_forwarded = true;
+ resources = [
+ {
+ names = ["client" "federation"];
+ compress = false;
+ }
+ ];
+ }
+ ];
};
# matrix needs a database
#
@@ -50,16 +58,16 @@ in {
virtualHosts = {
# route to matrix-synapse
"${config.networking.domain}" = {
- locations."= /.well-known/matrix/server".extraConfig =
- let server = { "m.server" = "${fqdn}:443"; };
- in ''
- add_header Content-Type application/json;
- return 200 '${builtins.toJSON server}';
- '';
+ locations."= /.well-known/matrix/server".extraConfig = let
+ server = {"m.server" = "${fqdn}:443";};
+ in ''
+ add_header Content-Type application/json;
+ return 200 '${builtins.toJSON server}';
+ '';
locations."= /.well-known/matrix/client".extraConfig = let
client = {
- "m.homeserver" = { "base_url" = "https://${fqdn}"; };
- "m.identity_server" = { "base_url" = "https://vector.im"; };
+ "m.homeserver" = {"base_url" = "https://${fqdn}";};
+ "m.identity_server" = {"base_url" = "https://vector.im";};
};
in ''
add_header Content-Type application/json;