summaryrefslogtreecommitdiff
path: root/Omni/Cloud/Hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Cloud/Hardware.nix')
-rw-r--r--Omni/Cloud/Hardware.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/Omni/Cloud/Hardware.nix b/Omni/Cloud/Hardware.nix
new file mode 100644
index 0000000..8fdbd4e
--- /dev/null
+++ b/Omni/Cloud/Hardware.nix
@@ -0,0 +1,9 @@
+{ modulesPath, ... }: {
+ imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
+ boot.loader.grub.device = "/dev/vda";
+ boot.initrd.kernelModules = [ "nvme" ];
+ fileSystems."/" = {
+ device = "/dev/vda1";
+ fsType = "ext4";
+ };
+}