summaryrefslogtreecommitdiff
path: root/Omni/Cloud/Mail.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Cloud/Mail.nix')
-rw-r--r--Omni/Cloud/Mail.nix24
1 files changed, 11 insertions, 13 deletions
diff --git a/Omni/Cloud/Mail.nix b/Omni/Cloud/Mail.nix
index fa99cf3..d3f70bc 100644
--- a/Omni/Cloud/Mail.nix
+++ b/Omni/Cloud/Mail.nix
@@ -1,12 +1,11 @@
-{ ... }:
+{...}:
+/*
+Known issues:
-/* Known issues:
-
- - when the acme cert gets refreshed, you need to manually restart dovecot
- - when restarting dovecot, it might hang, in that case do:
- systemctl --job-mode=ignore-dependencies restart dovecot2 postfix
+- when the acme cert gets refreshed, you need to manually restart dovecot
+- when restarting dovecot, it might hang, in that case do:
+ systemctl --job-mode=ignore-dependencies restart dovecot2 postfix
*/
-
{
mailserver = {
enable = true;
@@ -15,7 +14,7 @@
alertAddress = "bsima@me.com";
};
fqdn = "simatime.com";
- domains = [ "simatime.com" "bsima.me" ];
+ domains = ["simatime.com" "bsima.me"];
certificateScheme = 3; # let's encrypt
enableImap = true;
enablePop3 = true;
@@ -35,18 +34,17 @@
"postmaster@simatime.com"
"abuse@simatime.com"
];
- catchAll = [ "simatime.com" "bsima.me" ];
+ catchAll = ["simatime.com" "bsima.me"];
quota = "10G";
};
"dev@simatime.com" = {
hashedPasswordFile = "/home/ben/hashed-mail-password";
- aliases = [ "dev@bsima.me" ];
+ aliases = ["dev@bsima.me"];
quota = "10G";
};
"nick@simatime.com" = {
- hashedPassword =
- "$6$31P/Mg8k8Pezy1e$Fn1tDyssf.1EgxmLYFsQpSq6RP4wbEvP/UlBlXQhyKA9FnmFtJteXsbJM1naa8Kyylo8vZM9zmeoSthHS1slA1";
- aliases = [ "nicolai@simatime.com" ];
+ hashedPassword = "$6$31P/Mg8k8Pezy1e$Fn1tDyssf.1EgxmLYFsQpSq6RP4wbEvP/UlBlXQhyKA9FnmFtJteXsbJM1naa8Kyylo8vZM9zmeoSthHS1slA1";
+ aliases = ["nicolai@simatime.com"];
quota = "1G";
};
};