summaryrefslogtreecommitdiff
path: root/Omni/Dev/Beryllium/Ollama.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Dev/Beryllium/Ollama.nix')
-rw-r--r--Omni/Dev/Beryllium/Ollama.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/Omni/Dev/Beryllium/Ollama.nix b/Omni/Dev/Beryllium/Ollama.nix
index 0018f49..3f2398e 100644
--- a/Omni/Dev/Beryllium/Ollama.nix
+++ b/Omni/Dev/Beryllium/Ollama.nix
@@ -10,6 +10,7 @@ If you want to spend time on it, spend time over there.
*/
let
pkg = pkgs.unstable.ollama;
+ ports = import ../../Cloud/Ports.nix;
in {
systemd.services.ollama = {
description = "ollama";
@@ -17,7 +18,7 @@ in {
wantedBy = ["multi-user.target"];
environment = {
- OLLAMA_HOST = "localhost:11434";
+ OLLAMA_HOST = "0.0.0.0:${toString ports.ollama}";
# Where to store LLM model files.
HOME = "%S/ollama";
OLLAMA_MODELS = "%S/ollama/models";