summaryrefslogtreecommitdiff
path: root/Omni/Dev/Beryllium/OpenWebui.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Dev/Beryllium/OpenWebui.nix')
-rw-r--r--Omni/Dev/Beryllium/OpenWebui.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/Omni/Dev/Beryllium/OpenWebui.nix b/Omni/Dev/Beryllium/OpenWebui.nix
new file mode 100644
index 0000000..7b95331
--- /dev/null
+++ b/Omni/Dev/Beryllium/OpenWebui.nix
@@ -0,0 +1,14 @@
+{config, ...}: let
+ ports = import ../../Cloud/Ports.nix;
+in {
+ config.virtualisation.oci-containers.backend = "docker";
+ config.virtualisation.oci-containers.containers.open-webui = {
+ image = "ghcr.io/open-webui/open-webui:main";
+ volumes = ["/var/lib/open-webui:/app/backend/data"];
+ environment = {
+ OLLAMA_BASE_URL = "http://127.0.0.1:${toString ports.ollama}";
+ PORT = ports.open-webui;
+ };
+ extraOptions = ["--network=host"];
+ };
+}