summaryrefslogtreecommitdiff
path: root/Omni/Dev/Lithium/Configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Dev/Lithium/Configuration.nix')
-rw-r--r--Omni/Dev/Lithium/Configuration.nix30
1 files changed, 14 insertions, 16 deletions
diff --git a/Omni/Dev/Lithium/Configuration.nix b/Omni/Dev/Lithium/Configuration.nix
index 91b7f59..e050d48 100644
--- a/Omni/Dev/Lithium/Configuration.nix
+++ b/Omni/Dev/Lithium/Configuration.nix
@@ -1,6 +1,8 @@
-{ lib, pkgs, ... }:
-
-let
+{
+ lib,
+ pkgs,
+ ...
+}: let
ghcCompiler = (import ../../Bild/Constants.nix).ghcCompiler;
ports = import ../../Cloud/Ports.nix;
in {
@@ -24,8 +26,7 @@ in {
fira-code-symbols
];
- environment.systemPackages =
- [ pkgs.nvtop pkgs.k3s pkgs.wemux pkgs.tmux pkgs.wireguard-tools ];
+ environment.systemPackages = [pkgs.nvtop pkgs.k3s pkgs.wemux pkgs.tmux pkgs.wireguard-tools];
hardware.opengl.enable = true;
@@ -68,13 +69,11 @@ in {
services.tor.settings.Nickname = "ydeee3q1cjo83tsuqcz";
services.tor.settings.AccountingMax = "10 GBytes";
services.tor.settings.AccountingStart = "month 1 1:00";
- services.tor.settings.ContactInfo =
- "ContactInfo pgp:66A6AD150399D970DCA4C4E6C8218B7D0BFDECCD ciissversion:2";
+ services.tor.settings.ContactInfo = "ContactInfo pgp:66A6AD150399D970DCA4C4E6C8218B7D0BFDECCD ciissversion:2";
services.bitcoind.mainnet.enable = true;
services.bitcoind.mainnet.dataDir = "/mnt/campbell/bitcoind-mainnet/data";
- services.bitcoind.mainnet.configFile =
- "/mnt/campbell/bitcoind-mainnet/bitcoin.conf";
+ services.bitcoind.mainnet.configFile = "/mnt/campbell/bitcoind-mainnet/bitcoin.conf";
services.bitcoind.mainnet.prune = 10000;
services.pcscd.enable = true;
@@ -118,18 +117,17 @@ in {
services.xserver.windowManager.xmonad.enable = true;
services.xserver.libinput.enable = true;
services.xserver.libinput.touchpad.tapping = true;
- services.xserver.modules = [ pkgs.xf86_input_wacom ];
+ services.xserver.modules = [pkgs.xf86_input_wacom];
services.xserver.wacom.enable = true;
services.jupyter.enable = true;
services.jupyter.port = ports.jupyter;
services.jupyter.ip = "*";
users.users.jupyter.group = "jupyter";
- users.groups.jupyter = { };
- services.jupyter.password =
- "'argon2:$argon2id$v=19$m=10240,t=10,p=8$nvQhgk+htbIYi961YYAf1w$ekpwiTT5L4+OAods0K7EDw'";
+ users.groups.jupyter = {};
+ services.jupyter.password = "'argon2:$argon2id$v=19$m=10240,t=10,p=8$nvQhgk+htbIYi961YYAf1w$ekpwiTT5L4+OAods0K7EDw'";
services.jupyter.kernels.python3 = let
- env = (pkgs.python3.withPackages (p:
+ env = pkgs.python3.withPackages (p:
with p; [
ipykernel
pandas
@@ -138,7 +136,7 @@ in {
matplotlib
sympy
ipywidgets
- ]));
+ ]);
in {
displayName = "py3";
argv = [
@@ -193,7 +191,7 @@ in {
(lib.strings.splitString "\n")
(lib.filter (s: s != ""))
];
- nix.settings.trusted-users = [ "root" "ben" ];
+ nix.settings.trusted-users = ["root" "ben"];
# This value determines the NixOS release with which your system is to be
# compatible, in order to avoid breaking some software such as database