summaryrefslogtreecommitdiff
path: root/Omni/Os/Boot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Os/Boot.nix')
-rw-r--r--Omni/Os/Boot.nix23
1 files changed, 12 insertions, 11 deletions
diff --git a/Omni/Os/Boot.nix b/Omni/Os/Boot.nix
index c789d89..bfbae8c 100644
--- a/Omni/Os/Boot.nix
+++ b/Omni/Os/Boot.nix
@@ -1,14 +1,15 @@
-{ bild }:
-/* This target creates a qcow2 image of a barebones NixOS VM which should be used
- to bootstrap a deployment target.
+{bild}:
+/*
+This target creates a qcow2 image of a barebones NixOS VM which should be used
+to bootstrap a deployment target.
- The workflow is like this:
+The workflow is like this:
- - bild this, you get a qcow2 image
- - go to https://cloud.digitalocean.com/images/custom_images
- - upload the image
- - start a new droplet with this image
- - once fully provisioned and accessible via ssh, the new droplet can be a deploy
- target for any other namespace
+- bild this, you get a qcow2 image
+- go to https://cloud.digitalocean.com/images/custom_images
+- upload the image
+- start a new droplet with this image
+- once fully provisioned and accessible via ssh, the new droplet can be a deploy
+ target for any other namespace
*/
-bild.droplet { imports = [ ./Base.nix ../Users.nix ]; }
+bild.droplet {imports = [./Base.nix ../Users.nix];}