summaryrefslogtreecommitdiff
path: root/Biz/Storybook.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Biz/Storybook.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Biz/Storybook.nix')
-rw-r--r--Biz/Storybook.nix19
1 files changed, 11 insertions, 8 deletions
diff --git a/Biz/Storybook.nix b/Biz/Storybook.nix
index 692b4e9..147b789 100644
--- a/Biz/Storybook.nix
+++ b/Biz/Storybook.nix
@@ -1,6 +1,10 @@
-{ options, lib, config, pkgs, ... }:
-
-let
+{
+ options,
+ lib,
+ config,
+ pkgs,
+ ...
+}: let
cfg = config.services.storybook;
rootDomain = "bensima.com";
ports = import ../Omni/Cloud/Ports.nix;
@@ -27,8 +31,8 @@ in {
};
config = lib.mkIf cfg.enable {
systemd.services.storybook = {
- path = [ cfg.package pkgs.git ];
- wantedBy = [ "multi-user.target" ];
+ path = [cfg.package pkgs.git];
+ wantedBy = ["multi-user.target"];
preStart = ''
# these must be manually created
test -d /run/storybook
@@ -43,8 +47,7 @@ in {
Storybook
'';
serviceConfig = {
- Environment =
- [ "PORT=${toString cfg.port}" "AREA=Live" "DATA_DIR=${cfg.dataDir}" ];
+ Environment = ["PORT=${toString cfg.port}" "AREA=Live" "DATA_DIR=${cfg.dataDir}"];
EnvironmentFile = "/run/storybook/env";
KillSignal = "INT";
Type = "simple";
@@ -73,6 +76,6 @@ in {
};
};
- networking.firewall.allowedTCPPorts = [ ports.ssh ports.http ports.https ];
+ networking.firewall.allowedTCPPorts = [ports.ssh ports.http ports.https];
};
}