summaryrefslogtreecommitdiff
path: root/Biz/Storybook.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Storybook.nix')
-rw-r--r--Biz/Storybook.nix19
1 files changed, 11 insertions, 8 deletions
diff --git a/Biz/Storybook.nix b/Biz/Storybook.nix
index 692b4e9..147b789 100644
--- a/Biz/Storybook.nix
+++ b/Biz/Storybook.nix
@@ -1,6 +1,10 @@
-{ options, lib, config, pkgs, ... }:
-
-let
+{
+ options,
+ lib,
+ config,
+ pkgs,
+ ...
+}: let
cfg = config.services.storybook;
rootDomain = "bensima.com";
ports = import ../Omni/Cloud/Ports.nix;
@@ -27,8 +31,8 @@ in {
};
config = lib.mkIf cfg.enable {
systemd.services.storybook = {
- path = [ cfg.package pkgs.git ];
- wantedBy = [ "multi-user.target" ];
+ path = [cfg.package pkgs.git];
+ wantedBy = ["multi-user.target"];
preStart = ''
# these must be manually created
test -d /run/storybook
@@ -43,8 +47,7 @@ in {
Storybook
'';
serviceConfig = {
- Environment =
- [ "PORT=${toString cfg.port}" "AREA=Live" "DATA_DIR=${cfg.dataDir}" ];
+ Environment = ["PORT=${toString cfg.port}" "AREA=Live" "DATA_DIR=${cfg.dataDir}"];
EnvironmentFile = "/run/storybook/env";
KillSignal = "INT";
Type = "simple";
@@ -73,6 +76,6 @@ in {
};
};
- networking.firewall.allowedTCPPorts = [ ports.ssh ports.http ports.https ];
+ networking.firewall.allowedTCPPorts = [ports.ssh ports.http ports.https];
};
}