summaryrefslogtreecommitdiff
path: root/Omni/Bild/Deps.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Bild/Deps.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Bild/Deps.nix')
-rw-r--r--Omni/Bild/Deps.nix10
1 files changed, 4 insertions, 6 deletions
diff --git a/Omni/Bild/Deps.nix b/Omni/Bild/Deps.nix
index 3414418..0b23f9f 100644
--- a/Omni/Bild/Deps.nix
+++ b/Omni/Bild/Deps.nix
@@ -1,6 +1,4 @@
-_self: super:
-
-{
+_self: super: {
# Needs upgrading for guile 3
# inspekt3d = super.callPackage ./Deps/inspekt3d.nix {};
@@ -28,9 +26,9 @@ _self: super:
llm = super.overrideSrc super.llm super.sources.llm;
- nostr-rs-relay = super.callPackage ./Deps/nostr-rs-relay.nix { };
+ nostr-rs-relay = super.callPackage ./Deps/nostr-rs-relay.nix {};
- ollama = super.ollama.override { acceleration = "cuda"; };
+ ollama = super.ollama.override {acceleration = "cuda";};
- radicale = super.radicale.overrideAttrs (_old: { doCheck = false; });
+ radicale = super.radicale.overrideAttrs (_old: {doCheck = false;});
}