summaryrefslogtreecommitdiff
path: root/Omni/Bild/Deps/guile-opengl.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Bild/Deps/guile-opengl.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Bild/Deps/guile-opengl.nix')
-rw-r--r--Omni/Bild/Deps/guile-opengl.nix60
1 files changed, 34 insertions, 26 deletions
diff --git a/Omni/Bild/Deps/guile-opengl.nix b/Omni/Bild/Deps/guile-opengl.nix
index af01082..cb625e6 100644
--- a/Omni/Bild/Deps/guile-opengl.nix
+++ b/Omni/Bild/Deps/guile-opengl.nix
@@ -1,32 +1,40 @@
-{ stdenv, lib, fetchurl, pkg-config, guile, libGL, libGLU, freeglut }:
-
-let
+{
+ stdenv,
+ lib,
+ fetchurl,
+ pkg-config,
+ guile,
+ libGL,
+ libGLU,
+ freeglut,
+}: let
name = "guile-opengl-${version}";
version = "0.1.0";
-in stdenv.mkDerivation {
- inherit name;
+in
+ stdenv.mkDerivation {
+ inherit name;
- src = fetchurl {
- url = "mirror://gnu/guile-opengl/${name}.tar.gz";
- sha256 = "13qfx4xh8baryxqrv986l848ygd0piqwm6s2s90pxk9c0m9vklim";
- };
+ src = fetchurl {
+ url = "mirror://gnu/guile-opengl/${name}.tar.gz";
+ sha256 = "13qfx4xh8baryxqrv986l848ygd0piqwm6s2s90pxk9c0m9vklim";
+ };
- patchPhase = ''
- substituteInPlace glx/runtime.scm \
- --replace '(dynamic-link "libGL")' '(dynamic-link "${libGL}/lib/libGL.so")'
- substituteInPlace glu/runtime.scm \
- --replace '(dynamic-link "libGLU")' '(dynamic-link "${libGLU}/lib/libGLU.so")'
- substituteInPlace glut/runtime.scm \
- --replace '(dynamic-link "libglut")' '(dynamic-link "${freeglut}/lib/libglut.so")'
- '';
+ patchPhase = ''
+ substituteInPlace glx/runtime.scm \
+ --replace '(dynamic-link "libGL")' '(dynamic-link "${libGL}/lib/libGL.so")'
+ substituteInPlace glu/runtime.scm \
+ --replace '(dynamic-link "libGLU")' '(dynamic-link "${libGLU}/lib/libGLU.so")'
+ substituteInPlace glut/runtime.scm \
+ --replace '(dynamic-link "libglut")' '(dynamic-link "${freeglut}/lib/libglut.so")'
+ '';
- nativeBuildInputs = [ pkg-config guile libGL libGLU freeglut ];
+ nativeBuildInputs = [pkg-config guile libGL libGLU freeglut];
- meta = with lib; {
- description = "Guile bindings for the OpenGL graphics API";
- homepage = "https://www.gnu.org/software/guile-opengl/";
- license = licenses.gpl3Plus;
- maintainers = with maintainers; [ vyp ];
- platforms = platforms.all;
- };
-}
+ meta = with lib; {
+ description = "Guile bindings for the OpenGL graphics API";
+ homepage = "https://www.gnu.org/software/guile-opengl/";
+ license = licenses.gpl3Plus;
+ maintainers = with maintainers; [vyp];
+ platforms = platforms.all;
+ };
+ }