summaryrefslogtreecommitdiff
path: root/Omni/Bild/Deps/guile-opengl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Bild/Deps/guile-opengl.nix')
-rw-r--r--Omni/Bild/Deps/guile-opengl.nix60
1 files changed, 34 insertions, 26 deletions
diff --git a/Omni/Bild/Deps/guile-opengl.nix b/Omni/Bild/Deps/guile-opengl.nix
index af01082..cb625e6 100644
--- a/Omni/Bild/Deps/guile-opengl.nix
+++ b/Omni/Bild/Deps/guile-opengl.nix
@@ -1,32 +1,40 @@
-{ stdenv, lib, fetchurl, pkg-config, guile, libGL, libGLU, freeglut }:
-
-let
+{
+ stdenv,
+ lib,
+ fetchurl,
+ pkg-config,
+ guile,
+ libGL,
+ libGLU,
+ freeglut,
+}: let
name = "guile-opengl-${version}";
version = "0.1.0";
-in stdenv.mkDerivation {
- inherit name;
+in
+ stdenv.mkDerivation {
+ inherit name;
- src = fetchurl {
- url = "mirror://gnu/guile-opengl/${name}.tar.gz";
- sha256 = "13qfx4xh8baryxqrv986l848ygd0piqwm6s2s90pxk9c0m9vklim";
- };
+ src = fetchurl {
+ url = "mirror://gnu/guile-opengl/${name}.tar.gz";
+ sha256 = "13qfx4xh8baryxqrv986l848ygd0piqwm6s2s90pxk9c0m9vklim";
+ };
- patchPhase = ''
- substituteInPlace glx/runtime.scm \
- --replace '(dynamic-link "libGL")' '(dynamic-link "${libGL}/lib/libGL.so")'
- substituteInPlace glu/runtime.scm \
- --replace '(dynamic-link "libGLU")' '(dynamic-link "${libGLU}/lib/libGLU.so")'
- substituteInPlace glut/runtime.scm \
- --replace '(dynamic-link "libglut")' '(dynamic-link "${freeglut}/lib/libglut.so")'
- '';
+ patchPhase = ''
+ substituteInPlace glx/runtime.scm \
+ --replace '(dynamic-link "libGL")' '(dynamic-link "${libGL}/lib/libGL.so")'
+ substituteInPlace glu/runtime.scm \
+ --replace '(dynamic-link "libGLU")' '(dynamic-link "${libGLU}/lib/libGLU.so")'
+ substituteInPlace glut/runtime.scm \
+ --replace '(dynamic-link "libglut")' '(dynamic-link "${freeglut}/lib/libglut.so")'
+ '';
- nativeBuildInputs = [ pkg-config guile libGL libGLU freeglut ];
+ nativeBuildInputs = [pkg-config guile libGL libGLU freeglut];
- meta = with lib; {
- description = "Guile bindings for the OpenGL graphics API";
- homepage = "https://www.gnu.org/software/guile-opengl/";
- license = licenses.gpl3Plus;
- maintainers = with maintainers; [ vyp ];
- platforms = platforms.all;
- };
-}
+ meta = with lib; {
+ description = "Guile bindings for the OpenGL graphics API";
+ homepage = "https://www.gnu.org/software/guile-opengl/";
+ license = licenses.gpl3Plus;
+ maintainers = with maintainers; [vyp];
+ platforms = platforms.all;
+ };
+ }