summaryrefslogtreecommitdiff
path: root/Omni/Bild/Deps/inspekt3d.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Bild/Deps/inspekt3d.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Bild/Deps/inspekt3d.nix')
-rw-r--r--Omni/Bild/Deps/inspekt3d.nix23
1 files changed, 16 insertions, 7 deletions
diff --git a/Omni/Bild/Deps/inspekt3d.nix b/Omni/Bild/Deps/inspekt3d.nix
index 3146350..de3db4e 100644
--- a/Omni/Bild/Deps/inspekt3d.nix
+++ b/Omni/Bild/Deps/inspekt3d.nix
@@ -1,15 +1,24 @@
-{ stdenv, lib, autoreconfHook, pkg-config, guile, guile-opengl, mesa
-, glibcLocales, libfive, sources }:
-
+{
+ stdenv,
+ lib,
+ autoreconfHook,
+ pkg-config,
+ guile,
+ guile-opengl,
+ mesa,
+ glibcLocales,
+ libfive,
+ sources,
+}:
stdenv.mkDerivation {
name = "inspekt3d-unstable";
src = sources.inspekt3d;
version = "unstable-2018-10-17";
- nativeBuildInputs = [ pkg-config autoreconfHook ];
- buildInputs = [ guile glibcLocales mesa ];
- propagatedBuildInputs = [ guile-opengl libfive ];
+ nativeBuildInputs = [pkg-config autoreconfHook];
+ buildInputs = [guile glibcLocales mesa];
+ propagatedBuildInputs = [guile-opengl libfive];
preBuild = ''
substituteInPlace inspekt3d/library.scm \
@@ -24,7 +33,7 @@ stdenv.mkDerivation {
description = "Lightweight 3D viewer for Libfive written in Guile Scheme";
homepage = "https://sr.ht/~morgansmith/inspekt3d";
license = licenses.gpl3;
- maintainers = with maintainers; [ bsima ];
+ maintainers = with maintainers; [bsima];
platforms = platforms.all;
};
}