summaryrefslogtreecommitdiff
path: root/Omni/Bild/Deps/inspekt3d.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Bild/Deps/inspekt3d.nix')
-rw-r--r--Omni/Bild/Deps/inspekt3d.nix23
1 files changed, 16 insertions, 7 deletions
diff --git a/Omni/Bild/Deps/inspekt3d.nix b/Omni/Bild/Deps/inspekt3d.nix
index 3146350..de3db4e 100644
--- a/Omni/Bild/Deps/inspekt3d.nix
+++ b/Omni/Bild/Deps/inspekt3d.nix
@@ -1,15 +1,24 @@
-{ stdenv, lib, autoreconfHook, pkg-config, guile, guile-opengl, mesa
-, glibcLocales, libfive, sources }:
-
+{
+ stdenv,
+ lib,
+ autoreconfHook,
+ pkg-config,
+ guile,
+ guile-opengl,
+ mesa,
+ glibcLocales,
+ libfive,
+ sources,
+}:
stdenv.mkDerivation {
name = "inspekt3d-unstable";
src = sources.inspekt3d;
version = "unstable-2018-10-17";
- nativeBuildInputs = [ pkg-config autoreconfHook ];
- buildInputs = [ guile glibcLocales mesa ];
- propagatedBuildInputs = [ guile-opengl libfive ];
+ nativeBuildInputs = [pkg-config autoreconfHook];
+ buildInputs = [guile glibcLocales mesa];
+ propagatedBuildInputs = [guile-opengl libfive];
preBuild = ''
substituteInPlace inspekt3d/library.scm \
@@ -24,7 +33,7 @@ stdenv.mkDerivation {
description = "Lightweight 3D viewer for Libfive written in Guile Scheme";
homepage = "https://sr.ht/~morgansmith/inspekt3d";
license = licenses.gpl3;
- maintainers = with maintainers; [ bsima ];
+ maintainers = with maintainers; [bsima];
platforms = platforms.all;
};
}