summaryrefslogtreecommitdiff
path: root/Omni/Dev/Lithium/Hardware.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Dev/Lithium/Hardware.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Dev/Lithium/Hardware.nix')
-rw-r--r--Omni/Dev/Lithium/Hardware.nix17
1 files changed, 9 insertions, 8 deletions
diff --git a/Omni/Dev/Lithium/Hardware.nix b/Omni/Dev/Lithium/Hardware.nix
index 54c07f5..80d4e54 100644
--- a/Omni/Dev/Lithium/Hardware.nix
+++ b/Omni/Dev/Lithium/Hardware.nix
@@ -1,15 +1,16 @@
# Do not modify this file! It was generated by ‘nixos-generate-config’
# and may be overwritten by future invocations. Please make changes
# to /etc/nixos/configuration.nix instead.
-{ lib, modulesPath, ... }:
-
{
- imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
+ lib,
+ modulesPath,
+ ...
+}: {
+ imports = [(modulesPath + "/installer/scan/not-detected.nix")];
- boot.initrd.availableKernelModules =
- [ "xhci_pci" "ahci" "usb_storage" "usbhid" "sd_mod" ];
- boot.kernelModules = [ "kvm-intel" ];
- boot.extraModulePackages = [ ];
+ boot.initrd.availableKernelModules = ["xhci_pci" "ahci" "usb_storage" "usbhid" "sd_mod"];
+ boot.kernelModules = ["kvm-intel"];
+ boot.extraModulePackages = [];
fileSystems."/" = {
device = "/dev/disk/by-uuid/f08dd8f9-787c-4e2a-a0cc-7019edc2ce2b";
@@ -26,7 +27,7 @@
fsType = "ext4";
};
- swapDevices = [ ];
+ swapDevices = [];
powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
}