summaryrefslogtreecommitdiff
path: root/Omni/Dev/Lithium/Hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Dev/Lithium/Hardware.nix')
-rw-r--r--Omni/Dev/Lithium/Hardware.nix17
1 files changed, 9 insertions, 8 deletions
diff --git a/Omni/Dev/Lithium/Hardware.nix b/Omni/Dev/Lithium/Hardware.nix
index 54c07f5..80d4e54 100644
--- a/Omni/Dev/Lithium/Hardware.nix
+++ b/Omni/Dev/Lithium/Hardware.nix
@@ -1,15 +1,16 @@
# Do not modify this file! It was generated by ‘nixos-generate-config’
# and may be overwritten by future invocations. Please make changes
# to /etc/nixos/configuration.nix instead.
-{ lib, modulesPath, ... }:
-
{
- imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
+ lib,
+ modulesPath,
+ ...
+}: {
+ imports = [(modulesPath + "/installer/scan/not-detected.nix")];
- boot.initrd.availableKernelModules =
- [ "xhci_pci" "ahci" "usb_storage" "usbhid" "sd_mod" ];
- boot.kernelModules = [ "kvm-intel" ];
- boot.extraModulePackages = [ ];
+ boot.initrd.availableKernelModules = ["xhci_pci" "ahci" "usb_storage" "usbhid" "sd_mod"];
+ boot.kernelModules = ["kvm-intel"];
+ boot.extraModulePackages = [];
fileSystems."/" = {
device = "/dev/disk/by-uuid/f08dd8f9-787c-4e2a-a0cc-7019edc2ce2b";
@@ -26,7 +27,7 @@
fsType = "ext4";
};
- swapDevices = [ ];
+ swapDevices = [];
powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
}