summaryrefslogtreecommitdiff
path: root/Omni/Dev/Networking.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Dev/Networking.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Dev/Networking.nix')
-rw-r--r--Omni/Dev/Networking.nix16
1 files changed, 7 insertions, 9 deletions
diff --git a/Omni/Dev/Networking.nix b/Omni/Dev/Networking.nix
index c89add7..f7ea6e3 100644
--- a/Omni/Dev/Networking.nix
+++ b/Omni/Dev/Networking.nix
@@ -1,11 +1,10 @@
-{ ... }:
-
-let ports = import ../Cloud/Ports.nix;
+{...}: let
+ ports = import ../Cloud/Ports.nix;
in {
networking = {
- nameservers = [ "1.1.1.1" ];
+ nameservers = ["1.1.1.1"];
hostName = "lithium";
- hosts = { "::1" = [ "localhost" "ipv6-localhost" "ipv6-loopback" ]; };
+ hosts = {"::1" = ["localhost" "ipv6-localhost" "ipv6-loopback"];};
firewall = {
allowedTCPPorts = [
@@ -29,9 +28,9 @@ in {
ports.stableDiffusion
ports.tor
];
- allowedTCPPortRanges = [ ports.torrents ports.httpdev ];
- allowedUDPPorts = [ ports.dns ports.et ports.murmur ];
- allowedUDPPortRanges = [ ports.torrents ];
+ allowedTCPPortRanges = [ports.torrents ports.httpdev];
+ allowedUDPPorts = [ports.dns ports.et ports.murmur];
+ allowedUDPPortRanges = [ports.torrents];
};
# The global useDHCP flag is deprecated, therefore explicitly set to false here.
@@ -40,5 +39,4 @@ in {
useDHCP = false;
interfaces.enp2s0.useDHCP = true;
};
-
}