summaryrefslogtreecommitdiff
path: root/Omni/Dev/Networking.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Dev/Networking.nix')
-rw-r--r--Omni/Dev/Networking.nix16
1 files changed, 7 insertions, 9 deletions
diff --git a/Omni/Dev/Networking.nix b/Omni/Dev/Networking.nix
index c89add7..f7ea6e3 100644
--- a/Omni/Dev/Networking.nix
+++ b/Omni/Dev/Networking.nix
@@ -1,11 +1,10 @@
-{ ... }:
-
-let ports = import ../Cloud/Ports.nix;
+{...}: let
+ ports = import ../Cloud/Ports.nix;
in {
networking = {
- nameservers = [ "1.1.1.1" ];
+ nameservers = ["1.1.1.1"];
hostName = "lithium";
- hosts = { "::1" = [ "localhost" "ipv6-localhost" "ipv6-loopback" ]; };
+ hosts = {"::1" = ["localhost" "ipv6-localhost" "ipv6-loopback"];};
firewall = {
allowedTCPPorts = [
@@ -29,9 +28,9 @@ in {
ports.stableDiffusion
ports.tor
];
- allowedTCPPortRanges = [ ports.torrents ports.httpdev ];
- allowedUDPPorts = [ ports.dns ports.et ports.murmur ];
- allowedUDPPortRanges = [ ports.torrents ];
+ allowedTCPPortRanges = [ports.torrents ports.httpdev];
+ allowedUDPPorts = [ports.dns ports.et ports.murmur];
+ allowedUDPPortRanges = [ports.torrents];
};
# The global useDHCP flag is deprecated, therefore explicitly set to false here.
@@ -40,5 +39,4 @@ in {
useDHCP = false;
interfaces.enp2s0.useDHCP = true;
};
-
}