summaryrefslogtreecommitdiff
path: root/Urbit/Harbor.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Urbit/Harbor.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Urbit/Harbor.nix')
-rw-r--r--Urbit/Harbor.nix66
1 files changed, 35 insertions, 31 deletions
diff --git a/Urbit/Harbor.nix b/Urbit/Harbor.nix
index 6098163..fb18d0a 100644
--- a/Urbit/Harbor.nix
+++ b/Urbit/Harbor.nix
@@ -1,31 +1,37 @@
-{ options, lib, config, pkgs, ... }:
-
-/* Urbit Harbor is a supervisor for Urbit ships on the local machine. It does no
- orchestration, it just manages systemd services.
-
- Setup process:
-
- <running as user "urbit-harbor">
- dir=/var/urbit/harbor
- urbit -c $dir/zod -k $dir/zod.key -x # one-time setup
- <create $dir/zod.service from some template>
- systemctl --user enable $dir/zod.service # nees fullpath
- systemctl --user start zod.service
-
- Service Template:
-
- [Service]
- ExecStart=urbit -tq /var/urbit/harbor/zod # maybe want -d?
- ExecStartPre=mkdir -p /var/urbit/harbor/zod
-
- [Unit]
- Description=zod
-
- [Install]
- WantedBy=multi-user.target
+{
+ options,
+ lib,
+ config,
+ pkgs,
+ ...
+}:
+/*
+Urbit Harbor is a supervisor for Urbit ships on the local machine. It does no
+orchestration, it just manages systemd services.
+
+Setup process:
+
+ <running as user "urbit-harbor">
+ dir=/var/urbit/harbor
+ urbit -c $dir/zod -k $dir/zod.key -x # one-time setup
+ <create $dir/zod.service from some template>
+ systemctl --user enable $dir/zod.service # nees fullpath
+ systemctl --user start zod.service
+
+Service Template:
+
+ [Service]
+ ExecStart=urbit -tq /var/urbit/harbor/zod # maybe want -d?
+ ExecStartPre=mkdir -p /var/urbit/harbor/zod
+
+ [Unit]
+ Description=zod
+
+ [Install]
+ WantedBy=multi-user.target
*/
-
-let cfg = config.services.urbit-harbor;
+let
+ cfg = config.services.urbit-harbor;
in {
options.services.urbitharbor = {
enable = lib.mkEnableOption "Enable urbit-harbor";
@@ -62,8 +68,8 @@ in {
config = lib.mkIf cfg.enable {
systemd.services.urbit-harbor = {
- path = [ cfg.package cfg.urbitPackage ];
- wantedBy = [ "multi-user.target" ];
+ path = [cfg.package cfg.urbitPackage];
+ wantedBy = ["multi-user.target"];
preStart = ''
mkdir -p ${cfg.dataDir}
'';
@@ -76,7 +82,5 @@ in {
RestartSec = "3";
};
};
-
};
-
}