summaryrefslogtreecommitdiff
path: root/Urbit/Harbor.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Urbit/Harbor.nix')
-rw-r--r--Urbit/Harbor.nix66
1 files changed, 35 insertions, 31 deletions
diff --git a/Urbit/Harbor.nix b/Urbit/Harbor.nix
index 6098163..fb18d0a 100644
--- a/Urbit/Harbor.nix
+++ b/Urbit/Harbor.nix
@@ -1,31 +1,37 @@
-{ options, lib, config, pkgs, ... }:
-
-/* Urbit Harbor is a supervisor for Urbit ships on the local machine. It does no
- orchestration, it just manages systemd services.
-
- Setup process:
-
- <running as user "urbit-harbor">
- dir=/var/urbit/harbor
- urbit -c $dir/zod -k $dir/zod.key -x # one-time setup
- <create $dir/zod.service from some template>
- systemctl --user enable $dir/zod.service # nees fullpath
- systemctl --user start zod.service
-
- Service Template:
-
- [Service]
- ExecStart=urbit -tq /var/urbit/harbor/zod # maybe want -d?
- ExecStartPre=mkdir -p /var/urbit/harbor/zod
-
- [Unit]
- Description=zod
-
- [Install]
- WantedBy=multi-user.target
+{
+ options,
+ lib,
+ config,
+ pkgs,
+ ...
+}:
+/*
+Urbit Harbor is a supervisor for Urbit ships on the local machine. It does no
+orchestration, it just manages systemd services.
+
+Setup process:
+
+ <running as user "urbit-harbor">
+ dir=/var/urbit/harbor
+ urbit -c $dir/zod -k $dir/zod.key -x # one-time setup
+ <create $dir/zod.service from some template>
+ systemctl --user enable $dir/zod.service # nees fullpath
+ systemctl --user start zod.service
+
+Service Template:
+
+ [Service]
+ ExecStart=urbit -tq /var/urbit/harbor/zod # maybe want -d?
+ ExecStartPre=mkdir -p /var/urbit/harbor/zod
+
+ [Unit]
+ Description=zod
+
+ [Install]
+ WantedBy=multi-user.target
*/
-
-let cfg = config.services.urbit-harbor;
+let
+ cfg = config.services.urbit-harbor;
in {
options.services.urbitharbor = {
enable = lib.mkEnableOption "Enable urbit-harbor";
@@ -62,8 +68,8 @@ in {
config = lib.mkIf cfg.enable {
systemd.services.urbit-harbor = {
- path = [ cfg.package cfg.urbitPackage ];
- wantedBy = [ "multi-user.target" ];
+ path = [cfg.package cfg.urbitPackage];
+ wantedBy = ["multi-user.target"];
preStart = ''
mkdir -p ${cfg.dataDir}
'';
@@ -76,7 +82,5 @@ in {
RestartSec = "3";
};
};
-
};
-
}